Skip to main content
Gerry | Vanagon
Checking account...
← vanagon.com home · Continue the discussion in the forum
VanagonEuroVan
Subject:Re: Archive character encoding issue - SERVER ADMIN?
From:Mike S
Date:Wed, 13 Aug 2008 21:43:50 -0400

At 08:59 PM 8/13/2008, Chris S wrote...
>I don't know if you, the server admin, are aware of an issue with
>character encoding and translation in the archives of
>gerry.vanagon.com. When I use gmail set to my native language, Polish,
...
>   *Content-Type:* text/plain; charset=ISO-8859-2

Well, you're not sending plain ASCII text messages, so it's no surprise
that your MIME encoded messages using a different character set aren't
understood by the archiving system. Any email using MIME or encoding
other than ASCII can only be assumed to be understood when there is
common agreement that the alternate encoding is acceptable. As RFC 2822
states:

"This standard specifies a syntax only for text messages.  In
particular, it makes no provision for the transmission of images,
audio, or other sorts of structured data in electronic mail messages.
There are several extensions published, such as the MIME document
series [RFC2045, RFC2046, RFC2049], which describe mechanisms for the
transmission of such data through electronic mail, either by extending
the syntax provided here or by structuring such messages to conform to
this syntax.  Those mechanisms are outside of the scope of this
standard.'"

Have something to add on this topic today? Revive this thread in the forum »